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Installing Executable-image GEMPACK prior to laptop-based course 

We ask that you install GEMPACK (and possibly RunDynam) on your laptop prior to the course. This will 

save time during the course, and might identify problems which your own IT support could help fix. 
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1. Preparing for the installation 

Download Executable-Image GEMPACK from http://www.copsmodels.com/gpeidl.htm 

That page mentions a longer install document, GPinstall.pdf, but you should follow these shorter instructions. 

1.1 System Requirements 

 A Laptop PC running Windows 7 or later. 

 At least 4 GB free hard disk space on drive C: 

 4 GB memory (RAM) or more 

 The laptop must be able to "open a DOS box" [Start...Run..."cmd"]. Occasionally system 

administrators configure PCs to prevent this. 

To install the software, you will need "Administrator" rights. If your laptop belongs to, or was configured by, 

your organization's IT section, you may only have limited or "Standard User" access rights. In that case an 

Administrator password may be needed to install GEMPACK. This could mean that someone from your 

organization's IT section has to be present during the install. 

1.2 Installation location and managing existing installations 

The installer program will install GEMPACK into the folder C:\GP. 

It is possible that your computer already has an installation of GEMPACK in C:\GP. 

http://www.copsmodels.com/gpeidl.htm
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We prefer that you use the latest Executable-image GEMPACK as downloaded from the GEMPACK 

website.  This is because parts of the course exercises may have been written to accompany this particular 

version of the software. 

Please check whether you already have a folder C:\GP.  If so then 

rename the existing C:\GP folder to C:\GPOLD. 

Do this now.  This preserves the existing installation of GEMPACK, and any other files in this 

folder, for the duration of the course.  When the course is finished you can return your computer to 

its previous state by deleting the course C:\GP directory, and then renaming C:\GPOLD to C:\GP. 

2. Installing Executable-Image GEMPACK 

2.1 Installation 

Locate the installer program and follow the steps below. 

1. From Windows Explorer or My Computer, double-click the installer EXE. It may have a name such as  

gpei-12.0.004-install.exe. 

2. A warning window might appear. You may need to supply an Administrator password to continue. 

3. The installer program will begin. 

4. Licence Agreement.  To agree to the copyright conditions click I agree then click Next. 

5. Destination location.  Please accept the suggested C:\GP directory, and click Next. 

6. Changes to your PATH and Environment.  We ask that you agree to the suggested changes to the 

PATH and GPDIR variables, and click Next. 

7. Selecting a GEMPACK licence file.  Using your course CD or the course download package click 

Browse and go to the appropriate folder and select the licen.gem file.  If you do not have your course CD 

or download package then a temporary licence will be automatically created for you.  Click Next to 

continue. 

8. Ready to begin installation.  This window displays your installation choices.  Review your choices, 

click Back to make corrections.  When you are ready click Next to begin the installation. 

9. Finished.  The program signals that Installation is finished. Just click Finish. 

Sometimes, just after installation, Windows shows a warning message similar to that below: 

 

You should just click "This program installed correctly" as indicated above. 

2.2 Folder permissions 

Users need full access (read, write, and delete) to the GEMPACK installation folder C:\GP. If you performed 

the installation above in section 2.1 using the user account which will be used at the course then you have 

sufficient access, and you don’t need to change permissions on C:\GP. If you performed the installation 

using an administrator level account that will not be used at the course, please ensure that the user account to 
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be used at the course has full access to the C:\GP folder. One way to do this is to give the USERS group full 

access to C:\GP. 

3. A Quick Test of the GEMPACK installation 

This section leads you through a 5 minute test of your installation.  We strongly recommend that you 

perform this test. 

Start WinGEM by double clicking the WinGEM icon on your desktop: .  WinGEM starts as a 

taskbar across the top of your desktop: 

 

 

3.1 How to check your GEMPACK licence 

Go to the Options→Check GEMPACK licence menu item.  You should see a window appear with a text box 

containing the details of the licence created by the install program, or of the licence you selected during the 

installation.  If a window appears reporting that the file C:\GP\licen.gem could not be found then for some 

reason the licence file was not copied or made during the installation. Try installing again, then again try the 

Check GEMPACK licence.  

3.2 How to run a quick simulation 

Go to the WinGEM menu File → Change both default directories, and in the window that appears, double-

click to navigate through the folders to C:\GP\examples.  Click Select Folder. 
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Return to the WinGEM taskbar and select the Simulation → TABLO Implement menu item.  The TABLO 

window will appear.  Check that the GEMSIM option (near top right) is selected.  Now click on the Select 

button and open the SJ.TAB file from amongst those that are listed.  The window should now look like this.  

 

Now click on the Run button and after a few seconds some more buttons will appear in the TABLO window.  

Click on the Go to GEMSIM button, see below. (If instead an “Error running Tablo” window appears, go on 

to the troubleshooting section below.) 

 

In the GEMSIM window which appears click the Select button and open the file SJLB.CMF.  Now click on 

the Run button, and after a few seconds you will see some more buttons appear on the GEMSIM window and 

another new window will appear containing a bar chart and two smiley faces, see below.  (If instead an error 

message appears go on to the troubleshooting section below.) 
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If you got this far then your quick simulation test is successful.  Well done!  Take a moment to look at your 

desktop and discover the new program icons there, then skip ahead to section 5 below. 

4. If there is a problem 

If you encounter a problem during the installation, please follow these steps: 

 Re-read these instructions and install GEMPACK again. If there is still a problem ... 

 Try the "quick fix" mentioned in the next subsection. If that doesn't help ... 

 Study the full install document, gpinstall.pdf (downloadable from www.copsmodels.com/gpeidl.htm), 

and follow the procedure suggested there. Still no luck ... 

 Send an email to support@gempack.com carefully describing your problem. If possible attach the 

diagnostic file which you can produce using ViewHAR . In ViewHAR, go Help....About/Diagnostics 

and press the Diagnostics button. A diagnostic file should be displayed, which you can save or copy to 

the clipboard. 

4.1 A quick fix 

Various problems sometimes occur if the TEMP or USER folders have very long names or contain spaces or 

non-english characters. The latter might occur if your username contains non-english characters, or if you are 

running an Asian version of Windows. The following remedy does no harm and can often fix puzzling 

problems. 

1. Create a folder C:\TEMP  (if it does not exist already). 

2. Create a folder C:\GPKEEP  (if it does not exist already). 

3. Set the User Environment variable called TMP to be C:\TEMP .  

4. Set the User Environment variable called TEMP to be C:\TEMP .  

5. Create a User Environment variable called GPKEEP and set it to C:\GPKEEP .  

6. Reboot. 

You can set User Environment variables as follows: 

1. Select in turn: Control panel | Classic view | System | Advanced system settings | Environment Variables. 

2. Edit the User Environment variable TMP to be C:\TEMP.  Edit the User Environment variable TEMP to 

be C:\TEMP.  Make a New environment variable called GPKEEP with value C:\GPKEEP . 

For (much) more detail, please see the full install document, gpinstall.pdf (this is the same as Chapter 2 of 

the GEMPACK manual (gpmanual.htm or gpmanual.pdf). 

4.2 Antivirus packages 

Occasionally we have seen some antivirus programs object to GEMPACK programs – or even delete them. 

Usually there is a way to circumvent this by instructing the antivirus program to regard user-nominated (eg, 

GEMPACK) programs as safe. See: www.copsmodels.com/gpconfav.htm 

mailto:support@gempack.com


quickinst.doc  27/05/19 

    6 

5. Installing RunDynam (some courses only) 

If you are attending a course using a "dynamic" CGE model, you will need to install RunDynam. Otherwise, 

skip this section. 

Go to www.copsmodels.com/gprddl.htm and download the install package (it will have a name like 

rundynam-install-380.exe) and follow the steps below. 

1. Using Windows Explorer or My Computer, double-click the rundynam-install-380.exe installer 

program. 

2. A warning window might appear. You may need to supply an Administrator password to continue. 

3. The installer program will begin. 

4. Welcome and copyright warning.  To agree to the copyright conditions click Next. 

5. Destination location.  Please accept the suggested C:\RunDynam directory, and click Next. 

6. Selecting a RunDynam licence file.  Using your course CD or the course downloaded package click 

Browse and go to the appropriate folder and select the licen.rdn file.  If you do not have your course 

CD or download package then you do not need to do anything; a temporary trial licence will be 

created for you.  Click Next to continue. 

7. Start installation.  Click Next to begin the installation. 

8. Finished.  The program signals that Installation is finished. Just click Finish. 

You will now have a RunDynam icon on your desktop 

6. Notes on Course GEMPACK installation 

Course participants receive the latest Executable-Image Version of GEMPACK (and perhaps RunDynam), 

with course licences that may be used for some months after the course. In some cases the licence may 

restrict the size of models. In that case the software allows the full range of modelling tasks (building new 

models or modifying existing models), but models are limited to those that can be implemented and solved 

within about 32 megabytes of memory. This is large enough for many medium-sized models (including all 

course exercises) but not sufficient for large models. For larger models, you would need one of the more 

expensive alternatives: 

 Source Code version of GEMPACK and a Fortran compiler, or 

 Unlimited Executable-Image Version of GEMPACK. 

Some course participants may have access at work to the Source Code version of GEMPACK. In that case, 

they should NOT install the Limited Executable-Image GEMPACK at work without first consulting 

experienced colleagues. 

The simplified installation instructions in this document are rather rigid: eg, you must install in C:\GP. After 

the course, you could install GEMPACK on your office and home PC, following the detailed instructions in 

document GPinstall.pdf -- which allow more flexibility.  To install GEMPACK, you will need Administrator 

rights. 

7. Upgrading the expiring licence 

Course participants will receive a course-specific licence lasting some months from the start of the course.  

This licence will be on the course CD and may also be emailed to participants.  If your licence has expired 

and you with to obtain another please contact the GEMPACK business manager at sales@gempack.com.  

More information about GEMPACK versions and prices are on this web page: 

http://www.copsmodels.com/gpprice.htm. 

mailto:sales@gempack.com
http://monash.edu/policy/gpprice.htm

